Welcome to Volvo XC90 Forum, is this your first visit? Click the "Create Account" button now to join.
Register


User Tag List

Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Sep 2017
    Location
    Twin Falls
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Likes
    1


    My first XC90 and am having issues

    Guest-only advertisement. Register or Log In now!
    Hey guys, this is my first XC90. It's an '05 with the V-8, has 196K miles. I believe I am having some transmission issues. The car goes real smooth on the up shift when picking up speed. As soon as I back off on the throttle, it shakes like the motor is falling out. When I'm coasting down on speed, you can feel the jerk when it down shifts. On one of those shakes, it did something to the rear main. It's leaking oil, leaving about a 12" spot in an hour. What I'm asking is this a common problem or is there something else going on? Any input?

  2. #2
    New Member
    Join Date
    Jul 2018
    Location
    Winnipeg
    Posts
    10
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Total Likes
    1


    Have you taken it in. With engine shudders, the first thing I check is the motor mounts, if the rubber motor mount has failed vibration is not isolated and dampened and can cause these issues

    Bmoe

  3. #3
    New Member
    Join Date
    Sep 2017
    Location
    Twin Falls
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Likes
    1


    @Bmoe99 , I haven't taken it to the dealership. Closest dealership is 180 miles away. Did find a guy here that doesn't mind working on Volvo's. The motor mounts and transmission mounts have been replaced as well as the top cross bar mounts. Still has the problem. If I keep under 35 mph, you can feel the jerk when it downshifts, over that, it shakes hard. The faster I go, the worst it gets. I talked to the Volvo tech and he says transmission. I'm not sure if it could be the torque converter not releasing or what. The oil leak I saw is from the power steering pump. Got that fixed. Right now I'm keeping a lookout for a used transmission and will try that.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •